Magento 2 WebRotate360 Help

Are you using WebRotate 360 Product Viewer for Magento?
ThermalShock
Posts: 1
Joined: Tue Jan 29, 2019 1:57 pm
Contact:

Magento 2 WebRotate360 Help

Postby ThermalShock » Tue Jan 29, 2019 2:03 pm

So I'm trying to put together a proof of concept using this extension. I've got the module installed. I've enabled the integration in the module config. I've created the webroot_path attribute and put it into my product with a path of "/360_assets/PRO4896/config.xml" and put my files into "pub/static/frontend/Magento/luma/en_US/WebRotate360_ProductViewerStandard/360_assets/PRO4896".

When I try to go into a product view for my item I get the following error -

Code: Select all

1 exception(s):
Exception #0 (Exception): Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/main/app/code/WebRotate360/ProductViewerStandard/Helper/Data.php on line 154
Exception #0 (Exception): Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/main/app/code/WebRotate360/ProductViewerStandard/Helper/Data.php on line 154
#0 [internal function]: Magento\Framework\App\ErrorHandler->handler(2, 'count(): Parame...', '/var/www/html/m...', 154, Array)
#1 /var/www/html/main/app/code/WebRotate360/ProductViewerStandard/Helper/Data.php(154): count(Object(stdClass))
#2 /var/www/html/main/app/code/WebRotate360/ProductViewerStandard/view/frontend/templates/standard.phtml(11): WebRotate360\ProductViewerStandard\Helper\Data->getSwatches()
#3 /var/www/html/main/vendor/magento/framework/View/TemplateEngine/Php.php(59): include('/var/www/html/m...')


I'm assuming I need to add something else to the product, but the guide appears to be incomplete.

Any timely assistance would be greatly appreciated.
Cheers.

WebSupport
Posts: 963
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: Magento 2 WebRotate360 Help

Postby WebSupport » Tue Jan 29, 2019 7:39 pm

Hi! Hmm... it's hard to say from the log alone what exactly happened.

So far it seems there's an issue with some custom configurable attributes in your store, so may be as the first step, please try to create a simple product and assign the xml there as you did above and see if it shows up in the gallery. And we can the investigate further based on the result.


Return to “Magento Integration”

cron