Hotspot size and appearance inconsistent across browsers

Everything related to WebRotate 360 desktop tools and utilities.
basest
Posts: 1
Joined: Mon Jul 20, 2020 12:41 pm
Contact:

Hotspot size and appearance inconsistent across browsers

Postby basest » Tue Jul 21, 2020 7:37 am

I altered one of the stock hotspots (changed the color) and re-saved it with the same name. I also imported a copy of the same SVG with a new name. On Safari, everything works as expected, and the SVGs display at their natural size. On Firefox, my edited SVG does not show up at all, neither does the newly imported file, and on Chrome the edited file and the newly imported ones display at very large sizes, about 3X what I expect them to do. I switched out one of the hotspots with a completely different, unedited native-to-WebRotate SVG, and on all three browsers it looks fine. Is this a known issue? how do I get around it?

thanks for any help

WebSupport
Posts: 1061
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: Hotspot size and appearance inconsistent across browsers

Postby WebSupport » Tue Jul 21, 2020 10:01 am

Please see if width and height attributes are present in your custom SVGs (open them for edit in a text editor):

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="25px" height="25px" viewBox="0 0 25 25" ....>


Return to “Desktop Software - SpotEditor”

cron