not able to view the sample image

Any issues or questions about WebRotate 360 Product Viewer for OpenCart
sandeep
Posts: 1
Joined: Sun Apr 05, 2015 9:20 pm
Contact:

not able to view the sample image

Postby sandeep » Sun Apr 05, 2015 9:27 pm

hi,

i have integrated webrotate 360 into my opencart. installation was all fine. i didn't got any errors,but not able to view the sampleshoe in my demo frontend. my demo store url is http://www.silentflutes.com/ecommerce/index.php?route=product/product&path=59_60&product_id=50.Please help me out in this issue.

thank you

WebSupport
Posts: 972
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: not able to view the sample image

Postby WebSupport » Mon Apr 06, 2015 8:46 pm

Hi there! It looks like you would just need to change your Config File URL in admin for this product to either this (i.e add www.):

Code: Select all

http://www.silentflutes.com/ecommerce/360assets/sampleshoe/config.xml


or this, which is better as this path is relative (and doesn't depend on how users access the site, i.e with or without www as this can cause issues due to cross domain / same origin browser security which is what happened with your sample link - if you remove www in your sample link, it would load the sample 3D product view just fine):

Code: Select all

/ecommerce/360assets/sampleshoe/config.xml


Please let us know if this doesn't help.

ivankin1982
Posts: 3
Joined: Thu Jun 23, 2016 10:16 pm
Contact:

Re: not able to view the sample image

Postby ivankin1982 » Thu Jun 23, 2016 10:32 pm

hi,

i have integrated webrotate 360 (vqmod_webrotate360_def_product.xml) into my opencart.
installation was without any errors.
I can see that product.tpl was changed, but sample haven't worked.
I enabled WebRotate 360 module, finded one product and set "config file url" = /360assets/sampleshoe/config.xml
It haven't worked.
I tryed changing path to:
/opencart/360assets/sampleshoe/config.xml
http://localhost/opencart/360assets/sam ... config.xml
It haven't still worked.

Buy the way, I can see that if I set path to xml file it the table "Configure product views for each product", enable the product and press "Save" in fact it didn't save. Each time I save the test product with path to sample xml, it reset my path to empty field.

How can I fix it?

thank you

ivankin1982
Posts: 3
Joined: Thu Jun 23, 2016 10:16 pm
Contact:

Re: not able to view the sample image

Postby ivankin1982 » Fri Jun 24, 2016 10:37 am

P.S.
OpenCart 2.1

WebSupport
Posts: 972
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: not able to view the sample image

Postby WebSupport » Fri Jun 24, 2016 9:23 pm

Hi! When you edit the table with the xml path in the webrotate module settings, please try clicking outside of the grid after editing a row and before hitting the Save button. Does this help?

PS: this is a known focus issue with the grid and the reason we're reworking the OC module such that the xml path is edited under each product configuration page in admin.

ivankin1982
Posts: 3
Joined: Thu Jun 23, 2016 10:16 pm
Contact:

Re: not able to view the sample image

Postby ivankin1982 » Mon Jun 27, 2016 1:30 am

I tried this but it didn't fix the problem.
After I put the xml path into the table and then I clicked everythere. If I click "save" i could see than nothing changes.
I tried to save the xml path in Safari and Crome.
My module settings:
Module Enabled = Enabled
In the table "Configure product views for each product" I can see a couple of my test products.
I click the first row and set "enable=Yes" and put into "config file url" = opencart/360assets/sampleshoe/config.xml
Then I click at some different areas of page and press "save".
When I returned back to module360 settings, I can see - nothing was saved.

WebSupport
Posts: 972
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: not able to view the sample image

Postby WebSupport » Tue Jun 28, 2016 12:13 pm

This is strange. Can you possibly share your setup online so we could investigate?

PS: we will re-test on the latest OpenCart shortly to see if something new started affecting the plugin.

WebSupport
Posts: 972
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: not able to view the sample image

Postby WebSupport » Thu Jun 30, 2016 8:16 pm

Quick update: all is good so far in our tests using OC 2.1.0.1 with the default theme.

sos574
Posts: 6
Joined: Sat Feb 24, 2018 7:00 am
Contact:

Re: not able to view the sample image

Postby sos574 » Sat Mar 03, 2018 3:59 am

have you managed to run Webrotate on OpenCart? what and where should be changed?

myprojectbride
Posts: 1
Joined: Tue Oct 08, 2019 4:51 am
Contact:

Re: not able to view the sample image

Postby myprojectbride » Tue Oct 08, 2019 4:53 am

I found the solution. It is because of the font problem.
What I did to solve this was to paste the "/360assets/sampleshoe/config.xml" in the url section to make the "text" lose its "format". Then i re-copied it and pasted it in the table. Ta da!
Without the text font/format, it was finally able to save.


Return to “OpenCart Integration”