Full screen button not working in iframe

Having trouble getting started? The viewer isn't loading properly?
jazperson
Posts: 2
Joined: Wed Jan 27, 2016 10:39 pm
Contact:

Full screen button not working in iframe

Postby jazperson » Wed Jan 27, 2016 10:42 pm

Hi,

I made a fancybox iframe popup and inside the popup if my 360 product viewer. All buttons are working except for the full screen. It only works if the product viewer is not in the popup box. Any help? Thanks.

This is the link to the page where my button for 360 product viewer is located - [linked-removed]

WebSupport
Posts: 1016
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: Full screen button not working in iframe

Postby WebSupport » Thu Jan 28, 2016 11:32 am

Hi!

Please try adding allowfullscreen to your iframe element:

Code: Select all

<iframe src="..." width="..." height="..." frameborder="0" scrolling="no" allowfullscreen></iframe>

jazperson
Posts: 2
Joined: Wed Jan 27, 2016 10:39 pm
Contact:

Re: Full screen button not working in iframe

Postby jazperson » Thu Jan 28, 2016 3:46 pm

Thank you! It's now working.

molcha
Posts: 1
Joined: Thu Jul 06, 2017 7:40 am
Contact:

Re: Full screen button not working in iframe

Postby molcha » Thu Jul 06, 2017 8:08 am

Hi there,

Getting some problems with the full screen button & toolbar.

In free version toolbar doesn't showing at all, when I upload published files to the server.
It doesn't work for any browser.

http://molchanov.ws/b/ma.html

In license version it doesn't showing full screen button at any browser too.
In Chrome it docent showing all toolbar.

Any suggestions?

Thank you,

Andrew

WebSupport
Posts: 1016
Joined: Thu Aug 23, 2012 11:35 am
Location: Pasadena, CA
Contact:

Re: Full screen button not working in iframe

Postby WebSupport » Thu Jul 06, 2017 1:38 pm

Hi Andrew, looks like the issue is that your Apache webserver treats the .svg (vector) images that we use in the toolbar as text and reports them as text to the browser. To resolve, please add the following to your .htaccess:

Code: Select all

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

Copied from here:
https://davidwalsh.name/serve-svg-image


Return to “Setup Issues and Embedding”

cron